using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(.*) +([0-9,]+) +([\w]+)";
string input = @"This ingredient 0,5 g
This extra ingredient 11,7 cups
- od tega laktoza 3,6 g";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}