$re = '/(.*) +([0-9,]+) +([\w]+)/m';
$str = 'This ingredient 0,5 g
This extra ingredient 11,7 cups
- od tega laktoza 3,6 g';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);