re = /(.*) +([0-9,]+) +([\w]+)/m
str = 'This ingredient 0,5 g
This extra ingredient 11,7 cups
- od tega laktoza 3,6 g'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end