const regex = /(.*) +([0-9,]+) +([\w]+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(.*) +([0-9,]+) +([\\w]+)', 'gm')
const str = `This ingredient 0,5 g
This extra ingredient 11,7 cups
- od tega laktoza 3,6 g`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}