package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(.*) +([0-9,]+) +([\w]+)`)
var str = `This ingredient 0,5 g
This extra ingredient 11,7 cups
- od tega laktoza 3,6 g`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}