const regex = /fbq\('track'(?!.*?PageView)[^)]*\);/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('fbq\\(\'track\'(?!.*?PageView)[^)]*\\);', 'gm')
const str = `fbq('track', 'PageView');
fbq('track', 'PageView');
fbq('track', 'Purchase');
fbq('track', 'Purchase',
// begin parameter object data
{
value: 115.00,
currency: 'USD',
contents: [
{
id: '301',
quantity: 1
},
content_type: 'product'
}
// end parameter object data
);
fbq('track', 'PageView',
// begin parameter object data
{
value: 115.00,
currency: 'USD',
content_type: 'product'
}
// end parameter object data
);`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}