#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?s)\bJohn\b(?=(?>[^"]|(?<!\\)")*\\"/)"
Local $sString = "John \"John, Hello there John! \"/ John looks back. \"John, oh John! \"/ Not this John"
Local $sSubst = "Joe"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)