re = /\bJohn\b(?=(?>[^"]|(?<!\\)")*\\"\/)/
str = 'John \\"John, Hello there John! \\"/ John looks back. \\"John, oh John! \\"/ Not this John'
subst = 'Joe'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result