use strict;
my $str = 'John \\"John, Hello there John! \\"/ John looks back. \\"John, oh John! \\"/ Not this John';
my $regex = qr~\bJohn\b(?=(?>[^"]|(?<!\\)")*\\"/)~sp;
my $subst = 'Joe';
my $result = $str =~ s~$regex~$subst~rg;
print "The result of the substitution is' $result\n";