import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\bJohn\\b(?=(?>[^\"]|(?<!\\\\)\")*\\\\\"/)";
final String string = "John \\\"John, Hello there John! \\\"/ John looks back. \\\"John, oh John! \\\"/ Not this John";
final String subst = "Joe";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}