$re = '~\bJohn\b(?=(?>[^"]|(?<!\\\\)")*\\\\"/)~s';
$str = 'John \\"John, Hello there John! \\"/ John looks back. \\"John, oh John! \\"/ Not this John';
$subst = "Joe";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;