import Foundation
let pattern = #"\bJohn\b(?=(?>[^"]|(?<!\\)")*\\"/)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .dotMatchesLineSeparators)
let testString = #"John \"John, Hello there John! \"/ John looks back. \"John, oh John! \"/ Not this John"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"Joe"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)