package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`<[^<>&]+>(*SKIP)(*FAIL)|[<>&]+`)
var str = `<b>bold</b>, <strong>bold</strong>
<i>italic</i>, <em>italic</em>
<a href="http://www.example.com/" >inline URL</a>
<code>inline fixed-width code</code>
<pre>pre-formatted fixed-width code block</pre>
yes<b bad<>b> <bad& hi>;<strong >b<a<`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}