// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"<[^<>&]+>(*SKIP)(*FAIL)|[<>&]+").unwrap();
let string = "<b>bold</b>, <strong>bold</strong>
<i>italic</i>, <em>italic</em>
<a href=\"http://www.example.com/\" >inline URL</a>
<code>inline fixed-width code</code>
<pre>pre-formatted fixed-width code block</pre>
yes<b bad<>b> <bad& hi>;<strong >b<a<";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}