re = /<[^<>&]+>(*SKIP)(*FAIL)|[<>&]+/
str = '<b>bold</b>, <strong>bold</strong>
<i>italic</i>, <em>italic</em>
<a href="http://www.example.com/" >inline URL</a>
<code>inline fixed-width code</code>
<pre>pre-formatted fixed-width code block</pre>
yes<b bad<>b> <bad& hi>;<strong >b<a<'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end