import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<[^<>&]+>(*SKIP)(*FAIL)|[<>&]+";
final String string = "<b>bold</b>, <strong>bold</strong>\n"
+ "<i>italic</i>, <em>italic</em>\n"
+ "<a href=\"http://www.example.com/\" >inline URL</a>\n"
+ "<code>inline fixed-width code</code>\n"
+ "<pre>pre-formatted fixed-width code block</pre>\n"
+ "yes<b bad<>b> <bad& hi>;<strong >b<a<";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}