import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\][^\\[]+\\[.{10}[a-zA-Z\\s]+[\\d.]+";
final String string = "]43238[ tl02 ylpmiS murD liO elbategeV lm05 g001 /p 03.0$ notraC /p 76.53$";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}