const regex = new RegExp('\\][^\\[]+\\[.{10}[a-zA-Z\\s]+[\\d.]+', 'g')
const str = `]43238[ tl02 ylpmiS murD liO elbategeV lm05 g001 /p 03.0\$ notraC /p 76.53\$`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}