import re
regex = re.compile(r"\][^\[]+\[.{10}[a-zA-Z\s]+[\d.]+")
test_str = "]43238[ tl02 ylpmiS murD liO elbategeV lm05 g001 /p 03.0$ notraC /p 76.53$"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")