// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\][^\[]+\[.{10}[a-zA-Z\s]+[\d.]+").unwrap();
let string = "]43238[ tl02 ylpmiS murD liO elbategeV lm05 g001 /p 03.0$ notraC /p 76.53$";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}