re = /\][^\[]+\[.{10}[a-zA-Z\s]+[\d.]+/
str = ']43238[ tl02 ylpmiS murD liO elbategeV lm05 g001 /p 03.0$ notraC /p 76.53$'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end