#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m).*\.git|.*\.classpath|.*target|.*\.settings$"
Local $sString = "/var/share/repositories/Icinga/.git" & @CRLF & _
"/var/share/test" & @CRLF & _
"/var/share/.git" & @CRLF & _
".classpath" & @CRLF & _
"target" & @CRLF & _
"/help/.settings" & @CRLF & _
"/hello" & @CRLF & _
"/var/share/repositories/pep-mw-collect/.git/objects/pack/pack-1d6576907088dc6efa7fa64d2092695e07282083.idx" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")