const regex = new RegExp('.*\\.git|.*\\.classpath|.*target|.*\\.settings$', 'gm')
const str = `/var/share/repositories/Icinga/.git
/var/share/test
/var/share/.git
.classpath
target
/help/.settings
/hello
/var/share/repositories/pep-mw-collect/.git/objects/pack/pack-1d6576907088dc6efa7fa64d2092695e07282083.idx
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}