import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = ".*\\.git|.*\\.classpath|.*target|.*\\.settings$";
final String string = "/var/share/repositories/Icinga/.git\n"
+ "/var/share/test\n"
+ "/var/share/.git\n"
+ ".classpath\n"
+ "target\n"
+ "/help/.settings\n"
+ "/hello\n"
+ "/var/share/repositories/pep-mw-collect/.git/objects/pack/pack-1d6576907088dc6efa7fa64d2092695e07282083.idx\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}