import Foundation
let pattern = #".*\.git|.*\.classpath|.*target|.*\.settings$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
/var/share/repositories/Icinga/.git
/var/share/test
/var/share/.git
.classpath
target
/help/.settings
/hello
/var/share/repositories/pep-mw-collect/.git/objects/pack/pack-1d6576907088dc6efa7fa64d2092695e07282083.idx
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)