import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?<phone>\\+\\d{3,})(?:\\/((?&phone)))*$";
final String string = "# Should match because all numbers are different\n"
+ "+123\n"
+ "+123/+1234\n"
+ "+123/+1234/+12345\n\n"
+ "+12345/+1234/+123\n"
+ "+1234/+12345/+123\n\n"
+ "+1231/+1232/+1233\n\n"
+ "# should not match, because exact same number is present twice\n"
+ "+123/+1234/+123\n"
+ "+123/+123/+123\n"
+ "+123/+1234/+1234";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}