$re = '/^(?<phone>\+\d{3,})(?:\/((?&phone)))*$/m';
$str = '# Should match because all numbers are different
+123
+123/+1234
+123/+1234/+12345
+12345/+1234/+123
+1234/+12345/+123
+1231/+1232/+1233
# should not match, because exact same number is present twice
+123/+1234/+123
+123/+123/+123
+123/+1234/+1234';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);