import re
regex = re.compile(r"^(?<phone>\+\d{3,})(?:\/((?&phone)))*$", flags=re.MULTILINE)
test_str = ("# Should match because all numbers are different\n"
"+123\n"
"+123/+1234\n"
"+123/+1234/+12345\n\n"
"+12345/+1234/+123\n"
"+1234/+12345/+123\n\n"
"+1231/+1232/+1233\n\n"
"# should not match, because exact same number is present twice\n"
"+123/+1234/+123\n"
"+123/+123/+123\n"
"+123/+1234/+1234")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")