use strict;
my $str = '# Should match because all numbers are different
+123
+123/+1234
+123/+1234/+12345
+12345/+1234/+123
+1234/+12345/+123
+1231/+1232/+1233
# should not match, because exact same number is present twice
+123/+1234/+123
+123/+123/+123
+123/+1234/+1234';
my $regex = qr/^(?<phone>\+\d{3,})(?:\/((?&phone)))*$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}