// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(?<phone>\+\d{3,})(?:\/((?&phone)))*$").unwrap();
let string = "# Should match because all numbers are different
+123
+123/+1234
+123/+1234/+12345
+12345/+1234/+123
+1234/+12345/+123
+1231/+1232/+1233
# should not match, because exact same number is present twice
+123/+1234/+123
+123/+123/+123
+123/+1234/+1234";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}