using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(01\d+(?=17)|01\d+(?=10\w)|01\d+)?(17\d{6}(?=10))?(10[\d\w]+)?\+";
string input = @"1723022810736171730100+
17230228107361717+
0130409810928172302281073617173+
01655553410+
0145253462310DW381632+";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}