use strict;
my $str = '1723022810736171730100+
17230228107361717+
0130409810928172302281073617173+
01655553410+
0145253462310DW381632+';
my $regex = qr/(01\d+(?=17)|01\d+(?=10\w)|01\d+)?(17\d{6}(?=10))?(10[\d\w]+)?\+/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}