const regex = /(01\d+(?=17)|01\d+(?=10\w)|01\d+)?(17\d{6}(?=10))?(10[\d\w]+)?\+/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(01\\d+(?=17)|01\\d+(?=10\\w)|01\\d+)?(17\\d{6}(?=10))?(10[\\d\\w]+)?\\+', 'g')
const str = `1723022810736171730100+
17230228107361717+
0130409810928172302281073617173+
01655553410+
0145253462310DW381632+`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}