import re
regex = re.compile(r"(01\d+(?=17)|01\d+(?=10\w)|01\d+)?(17\d{6}(?=10))?(10[\d\w]+)?\+")
test_str = ("1723022810736171730100+\n"
"17230228107361717+\n"
"0130409810928172302281073617173+\n"
"01655553410+\n"
"0145253462310DW381632+")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")