$re = '/(01\d+(?=17)|01\d+(?=10\w)|01\d+)?(17\d{6}(?=10))?(10[\d\w]+)?\+/';
$str = '1723022810736171730100+
17230228107361717+
0130409810928172302281073617173+
01655553410+
0145253462310DW381632+';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);