import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(01\\d+(?=17)|01\\d+(?=10\\w)|01\\d+)?(17\\d{6}(?=10))?(10[\\d\\w]+)?\\+";
final String string = "1723022810736171730100+\n"
+ "17230228107361717+\n"
+ "0130409810928172302281073617173+\n"
+ "01655553410+\n"
+ "0145253462310DW381632+";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}