#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:0{0,})((?:[1-9]{1,2}|100)?(?:\.\d+)?)%?$"
Local $sString = "12.02" & @CRLF & _
"16.59" & @CRLF & _
"81.61%" & @CRLF & _
"45" & @CRLF & _
"24.812" & @CRLF & _
"51.35" & @CRLF & _
"19348952" & @CRLF & _
"88.223" & @CRLF & _
"0" & @CRLF & _
"000" & @CRLF & _
"021" & @CRLF & _
".85%" & @CRLF & _
"100" & @CRLF & _
"101" & @CRLF & _
"999.20%" & @CRLF & _
".0"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")