import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:0{0,})((?:[1-9]{1,2}|100)?(?:\\.\\d+)?)%?$";
final String string = "12.02\n"
+ "16.59\n"
+ "81.61%\n"
+ "45\n"
+ "24.812\n"
+ "51.35\n"
+ "19348952\n"
+ "88.223\n"
+ "0\n"
+ "000\n"
+ "021\n"
+ ".85%\n"
+ "100\n"
+ "101\n"
+ "999.20%\n"
+ ".0";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}