const regex = /^(?:0{0,})((?:[1-9]{1,2}|100)?(?:\.\d+)?)%?$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:0{0,})((?:[1-9]{1,2}|100)?(?:\\.\\d+)?)%?$', 'gm')
const str = `12.02
16.59
81.61%
45
24.812
51.35
19348952
88.223
0
000
021
.85%
100
101
999.20%
.0`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}