// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(?:0{0,})((?:[1-9]{1,2}|100)?(?:\.\d+)?)%?$").unwrap();
let string = "12.02
16.59
81.61%
45
24.812
51.35
19348952
88.223
0
000
021
.85%
100
101
999.20%
.0";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}