$re = '/^(?:0{0,})((?:[1-9]{1,2}|100)?(?:\.\d+)?)%?$/m';
$str = '12.02
16.59
81.61%
45
24.812
51.35
19348952
88.223
0
000
021
.85%
100
101
999.20%
.0';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);