use strict;
my $str = '12.02
16.59
81.61%
45
24.812
51.35
19348952
88.223
0
000
021
.85%
100
101
999.20%
.0';
my $regex = qr/^(?:0{0,})((?:[1-9]{1,2}|100)?(?:\.\d+)?)%?$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}