import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[aA-zZаА-яЯ]\\s([0-9])'?";
final String string = "FT 1 - 0 \n"
+ "Добавлено минут 1\n"
+ "HT 0 - 0 \n"
+ "Добавлено минут 5'\n"
+ "add minutes 3";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}