$re = '/[aA-zZаА-яЯ]\s([0-9])\'?/m';
$str = 'FT 1 - 0
Добавлено минут 1
HT 0 - 0
Добавлено минут 5\'
add minutes 3';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);