#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = ":\s*\'((?:(?!:\s*\'(?:.*):\s*\'(?:.*)).)+)\'"
Local $sString = "required : 'This 'asdf' "asdf" field is required!', dateISO : 'This is a test...', digit : 'Example: This is a plausible use of a colon in a jqValidate message.', number : ''Example': We probably do not use a colon together with single quotes like this, but we can.', range : 'Any 'text' here: This is a very unusual 'portion of text' - isn't it?', whatever : 'Last 'text' here: 'Even this combination is possible to use!''"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")