import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = ":\\s*\\'((?:(?!:\\s*\\'(?:.*):\\s*\\'(?:.*)).)+)\\'";
final String string = "required : 'This 'asdf' \"asdf\" field is required!', dateISO : 'This is a test...', digit : 'Example: This is a plausible use of a colon in a jqValidate message.', number : ''Example': We probably do not use a colon together with single quotes like this, but we can.', range : 'Any 'text' here: This is a very unusual 'portion of text' - isn't it?', whatever : 'Last 'text' here: 'Even this combination is possible to use!''";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}