import Foundation
let pattern = #":\s*\'((?:(?!:\s*\'(?:.*):\s*\'(?:.*)).)+)\'"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"required : 'This 'asdf' "asdf" field is required!', dateISO : 'This is a test...', digit : 'Example: This is a plausible use of a colon in a jqValidate message.', number : ''Example': We probably do not use a colon together with single quotes like this, but we can.', range : 'Any 'text' here: This is a very unusual 'portion of text' - isn't it?', whatever : 'Last 'text' here: 'Even this combination is possible to use!''"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)