using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @":\s*\'((?:(?!:\s*\'(?:.*):\s*\'(?:.*)).)+)\'";
string input = @"required : 'This 'asdf' ""asdf"" field is required!', dateISO : 'This is a test...', digit : 'Example: This is a plausible use of a colon in a jqValidate message.', number : ''Example': We probably do not use a colon together with single quotes like this, but we can.', range : 'Any 'text' here: This is a very unusual 'portion of text' - isn't it?', whatever : 'Last 'text' here: 'Even this combination is possible to use!''";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}