re = /:\s*\'((?:(?!:\s*\'(?:.*):\s*\'(?:.*)).)+)\'/
str = 'required : \'This \'asdf\' "asdf" field is required!\', dateISO : \'This is a test...\', digit : \'Example: This is a plausible use of a colon in a jqValidate message.\', number : \'\'Example\': We probably do not use a colon together with single quotes like this, but we can.\', range : \'Any \'text\' here: This is a very unusual \'portion of text\' - isn\'t it?\', whatever : \'Last \'text\' here: \'Even this combination is possible to use!\'\''
# Print the match result
str.scan(re) do |match|
puts match.to_s
end