# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\[\'(.+?)'\]/['$1']\n/gm;t' <<< "['ABC']['ABC.5']['ABC.5.1']"